読者です 読者をやめる 読者になる 読者になる

IPython + pandas + ggplot

目次へ

IPython 3 で ggplot の geom_histogram() がエラーになる

現在の ggplot 0.6.5 と pandas 0.16.0 の組み合わせで不具合があることが報告されている。

pivot_table "row" keyword not supported by pandas 0.16.0 #417

ggplot の新バージョンが近々リリースされるとの情報があるので期待したい。

pandas

Version: 0.16.2 final (June 12, 2015)

 次のコマンドで  pandas 0.15.2 をインストールすることができた。

conda install pandas=0.15.2

これを実行すれば  geom_histogram() のエラーは起こらないことを確認した。

ggplot for python

conda install -c https://conda.binstar.org/bokeh ggplot

ggplot 0.6.5 (2014-08-14)

yhat/ggplot/issues

実行例

目次へ